Apm servo çıkışlarında yaşadığım sorun

  • Forumdan daha fazla yararlanmak için buradan ÜYE olunuz

    Eğer eski üyemizseniz, MEVCUT Kullanıcı ADI ve ŞİFRENİZİ aynen kullanabilirsiniz. Eğer girişte sorun yaşıyorsanız, lütfen şu konuya TIKLAYINIZ.

Burak ER

Yeni Uye
Katılım
7 Haz 2021
Mesajlar
7
Tepkime puanı
2
Yaş
33
Konum
Bursa
İlgi Alanı
Multikopter
Merhabalar,

Apm 2.8 kullanıyorum pusula harici tüm kalibrasyonları kendim yaptım. Pusula kalibre gözüktüğü için yapmadım. Stabileze modda yarım gazda kopter sabit ayakları üstünde tüm açılar 0 olacak şekilde duruyorken; motor pwm çıkışları hepsinin aynı olması gerekirken birbirlerinden farklılar. Bu da kopterin farklı yönlere uçmaya çalışmasına neden oluyor. Bu sebepten daha uçurmadım. Resim ektedir. Görüldüğü gibi tüm outputlar tek bir değer alması gerekirken her bir motora farklı değerler gidiyor. Kumanda trimlerim orta eksende yani trim yok. Esc kalibrasyonu hepsi tamam. Tüm stikler orta noktada. Tüm parametreleri kontrol ettim am sonuç aynı.

Sebep ne olabilir?

Sorunumu çözen ne dilerse dilesin benden.​


You must be registered for see images attach
 
Kontrol Kartınız
APM 2.8
Model Sınıfı
Quadcopter S500
Motor, Pervane ve ESC
N/A
Kumanda Alıcı ve Verici
Turnigy 9x
Extra Ekipman
N/A
Moderatör tarafında düzenlendi:

Berk Eksin

Çalışkan Uye
Katılım
19 Tem 2020
Mesajlar
568
Tepkime puanı
456
Konum
Akhisar/Manisa
İlgi Alanı
Uçak
Merhabalar,

Apm 2.8 kullanıyorum pusula harici tüm kalibrasyonları kendim yaptım. Pusula kalibre gözüktüğü için yapmadım. Stabileze modda yarım gazda kopter sabit ayakları üstünde tüm açılar 0 olacak şekilde duruyorken; motor pwm çıkışları hepsinin aynı olması gerekirken birbirlerinden farklılar. Bu da kopterin farklı yönlere uçmaya çalışmasına neden oluyor. Bu sebepten daha uçurmadım. Resim ektedir. Görüldüğü gibi tüm outputlar tek bir değer alması gerekirken her bir motora farklı değerler gidiyor. Kumanda trimlerim orta eksende yani trim yok. Esc kalibrasyonu hepsi tamam. Tüm stikler orta noktada. Tüm parametreleri kontrol ettim am sonuç aynı.

Sebep ne olabilir?

Sorunumu çözen ne dilerse dilesin benden.​


You must be registered for see images attach
Hocam ben bu motor değerlerine baktığımda şunu anladım quadiniz şuan kendini sol öne doğru yatık hissediyor ve ona göre bir düzeltme uygulamaya çalışıyor. Gyro accel kalibrasyonunu tekrarlayın ve bu kalibrasyonu yaptığınız zemini düzgün olduğundan emin olun bunun için bir su terazisi vb birşey kullanabilirisiniz veya kumanda kalibrasyonu ile ilgili bir sıkıntı olabilir ve kumandadan sanki sağ arka çapraza gitmesi için komut geliyormuş gibi algılıyor olabilir kumanda kalibrasyonunuda tekrarlayın

Veya kalibrasyon düzgündür quadı uçurmaya çalıştığınız zemin eğimli olduğu ilk kalkarken küçük bir sapma ve yalpalama durumu olmuş olabilir.
 

Burak ER

Yeni Uye
Katılım
7 Haz 2021
Mesajlar
7
Tepkime puanı
2
Yaş
33
Konum
Bursa
İlgi Alanı
Multikopter
Hocam ben bu motor değerlerine baktığımda şunu anladım quadiniz şuan kendini sol öne doğru yatık hissediyor ve ona göre bir düzeltme uygulamaya çalışıyor. Gyro accel kalibrasyonunu tekrarlayın ve bu kalibrasyonu yaptığınız zemini düzgün olduğundan emin olun bunun için bir su terazisi vb birşey kullanabilirisiniz veya kumanda kalibrasyonu ile ilgili bir sıkıntı olabilir ve kumandadan sanki sağ arka çapraza gitmesi için komut geliyormuş gibi algılıyor olabilir kumanda kalibrasyonunuda tekrarlayın

Veya kalibrasyon düzgündür quadı uçurmaya çalıştığınız zemin eğimli olduğu ilk kalkarken küçük bir sapma ve yalpalama durumu olmuş olabilir.
Hocam cevabınız için teşekkür ederim.

Accel kalibrasyonunu neredeyse 10 kez yaptım. Hud da aldığım tüm açılar sıfır. Yani mükemmel hizalı. Yani tüm eksenler sıfıra sıfır. Kumandaya gelince stikler ortadayken reciever inputları orta noktada minimumken minimum noktada maksken maksimum pwm alıyorum. Tüm trimlerde sıfır kumanda üstünde. Yani herşey olması gerektiği gibi. Acaba bir parametrede sıkıntı mı var diyorum. Parametre olarak holybronun s500 parametrelerini kullanıyorum default olarak. Benim frame uygun olan o.

Quadın verdiği tepkilerde bir gariplik var. Hiç bir ayarda sapma yok iken böyle yapması beni düşündürüyor. Bu arada arducopter v3.2.1 kullanıyorum. Bilinen bir bugu falan var mı acaba.
 
Katılım
21 Ağu 2016
Mesajlar
139
Tepkime puanı
254
Yaş
34
İlgi Alanı
Multikopter
Hocam cevabınız için teşekkür ederim.

Accel kalibrasyonunu neredeyse 10 kez yaptım. Hud da aldığım tüm açılar sıfır. Yani mükemmel hizalı. Yani tüm eksenler sıfıra sıfır. Kumandaya gelince stikler ortadayken reciever inputları orta noktada minimumken minimum noktada maksken maksimum pwm alıyorum. Tüm trimlerde sıfır kumanda üstünde. Yani herşey olması gerektiği gibi. Acaba bir parametrede sıkıntı mı var diyorum. Parametre olarak holybronun s500 parametrelerini kullanıyorum default olarak. Benim frame uygun olan o.

Quadın verdiği tepkilerde bir gariplik var. Hiç bir ayarda sapma yok iken böyle yapması beni düşündürüyor. Bu arada arducopter v3.2.1 kullanıyorum. Bilinen bir bugu falan var mı acaba.
Merhaba,

Kullandığınız kartı uzun süre değişik ölçülerde quadcopterler ile bende kullandim. Birçok kez yeniden yükleme ve kalibrasyon işlemlerini yaptım. v3.2.1 yazılımı apm için son versiyondu galiba yanlış hatırlıyor da olabilirim. Ben yazılım desteği bitince pixhawk'a geçmiştim ve hala kullanıyorum. Başka quadcoptere ait parametreler kullanmak da sorun olabilir. Aslinda yazılımı yukleyip kalibrasyonları yapmak ve ilk uçuşu yapmak max 15 dk sürer neden farklı parametre denemeleri yapıyorsunuz?

İçinden çıkılmaz bir sorun olduğunda ki bu olmaz da, varsayalım oldu ve parametreler falan çok karıştı, farkli bir model yazılımı yükleyip (ör: rover ya da uçak) sonra tekrar quad yazılımı yükleyip bir nevi hard reset yapmış gibi tekrar kalibrasyonlari yapıp devam edebilirsiniz.

Bu islemi yapın, form turunuzu dogru seçin, accel kumanda, pusula, esc gibi elzem kalibrasyonlari yapın ve kalan degerleri stock olarak birakin.
Kontrol Kartinizda veya herhangi başka bir donanımınızda bir sorun yok ise bu şekilde bir başlangıç yapıp sonrasında PID ayarları için autotune yapabilirsiniz.
 

Burak ER

Yeni Uye
Katılım
7 Haz 2021
Mesajlar
7
Tepkime puanı
2
Yaş
33
Konum
Bursa
İlgi Alanı
Multikopter
Merhaba,

Kullandığınız kartı uzun süre değişik ölçülerde quadcopterler ile bende kullandim. Birçok kez yeniden yükleme ve kalibrasyon işlemlerini yaptım. v3.2.1 yazılımı apm için son versiyondu galiba yanlış hatırlıyor da olabilirim. Ben yazılım desteği bitince pixhawk'a geçmiştim ve hala kullanıyorum. Başka quadcoptere ait parametreler kullanmak da sorun olabilir. Aslinda yazılımı yukleyip kalibrasyonları yapmak ve ilk uçuşu yapmak max 15 dk sürer neden farklı parametre denemeleri yapıyorsunuz?
Şöyle anlatayım. Quad düz durumdayken yani yere paralelken; motor çıkışları, hepsi aynı olması gerekirken birbirlerinden farklı değer alıyorlar. Farklarda tolere edilebilir miktarda değil. Yani bu sebeple kopteri kaldırmaya çalışırken değişik hareketler yapıyor. Dolayısıyla zarar vermemek için uçuş denemiyorum. Bu ilk kopterim değil daha önce aynı kopteri(kumanda bağlantısı kopması sebebiyle kaybettim) yaptım.

İçinden çıkılmaz bir sorun olduğunda ki bu olmaz da, varsayalım oldu ve parametreler falan çok karıştı, farkli bir model yazılımı yükleyip (ör: rover ya da uçak) sonra tekrar quad yazılımı yükleyip bir nevi hard reset yapmış gibi tekrar kalibrasyonlari yapıp devam edebilirsiniz.
Bu hard reset olayı mantıklı geldi. Çünkü parametrelerin tek tek değişimi sonuca pek etkimiyor.

Bu islemi yapın, form turunuzu dogru seçin, accel kumanda, pusula, esc gibi elzem kalibrasyonlari yapın ve kalan degerleri stock olarak birakin.
Kontrol Kartinizda veya herhangi başka bir donanımınızda bir sorun yok ise bu şekilde bir başlangıç yapıp sonrasında PID ayarları için autotune yapabilirsiniz.
Hard reseti deneyip sonucu bildiricem.
 
  • Beğen
Tepkiler: Ali Osman SEVİM

Berk Eksin

Çalışkan Uye
Katılım
19 Tem 2020
Mesajlar
568
Tepkime puanı
456
Konum
Akhisar/Manisa
İlgi Alanı
Uçak
Hard reset denedim sonuç gene aynı.
Tam olarak uçuş yapmaya çalıştığınızda nasıl bir sonuç aldınız ayrıntılı anlatabilirmisiniz varsa video koyabilirmisiniz. Birde kullandığınız uçuş modu nedir. Şuan quad kendini yamuk hissediyor veya bir yerden komut alıyor bu uçuş koduda olabilir kumandada. Acaba kumandadan hiç trim verdiniz mi
 

Burak ER

Yeni Uye
Katılım
7 Haz 2021
Mesajlar
7
Tepkime puanı
2
Yaş
33
Konum
Bursa
İlgi Alanı
Multikopter
Tam olarak uçuş yapmaya çalıştığınızda nasıl bir sonuç aldınız ayrıntılı anlatabilirmisiniz varsa video koyabilirmisiniz. Birde kullandığınız uçuş modu nedir. Şuan quad kendini yamuk hissediyor veya bir yerden komut alıyor bu uçuş koduda olabilir kumandada. Acaba kumandadan hiç trim verdiniz mi

Tam olarak uçuş yapmaya çalıştığımda kalkışta quad düz kalkması gerekirken motorlara giden servo çıkışlarındaki farklılıktan dolayı rasgele hareketle kalkmaya çalışıyor. Kullandığım mod Stabilize. Kumanda trimlerini sıfırladım olmadı. Biraz trim vererek ayar yapmaya çalıştım çok farklı sonuçlar aldım. Bir yöndeki eğimi trimle kapatmaya çalıştığımda başka bir yönde eğim sonucuyla karşılaştım. Çok çok çok garip bir durum. Çözemiyorum.
 
Katılım
21 Ağu 2016
Mesajlar
139
Tepkime puanı
254
Yaş
34
İlgi Alanı
Multikopter
Tam olarak uçuş yapmaya çalıştığımda kalkışta quad düz kalkması gerekirken motorlara giden servo çıkışlarındaki farklılıktan dolayı rasgele hareketle kalkmaya çalışıyor. Kullandığım mod Stabilize. Kumanda trimlerini sıfırladım olmadı. Biraz trim vererek ayar yapmaya çalıştım çok farklı sonuçlar aldım. Bir yöndeki eğimi trimle kapatmaya çalıştığımda başka bir yönde eğim sonucuyla karşılaştım. Çok çok çok garip bir durum. Çözemiyorum.
Son denemede yüklemeden sonra gelen parametreler ile mi kullandınız. Yoksa tekrar bahsettiğiniz holybro nun S500 parametrelerini mi yüklediniz. Daha nerelere bakılabilir acaba bence de garip bir durum var kontrol karti yönü esc bağlantıları motor yönleri alakasız gibi duruyor ama acaba nereden çıkacak, başka kontrol edilebilcek yerler varmı diye düşünüyorum.
 

Mehmet Y. Sarıkaya

Kıdemli Uye
Katılım
28 Ocak 2018
Mesajlar
1,814
Tepkime puanı
3,630
Konum
Bar / Montenegro
İlgi Alanı
Uçak
Apm ile pek haşır neşir olmadım, Ancak kart arızalı değilse esc hatası olabilime ihtimali yüksek gibi. Farklı esc takımı ile denemekte fayda var.
Ayrıca bazı apm kartlarda pusula kendi üzerinde sanırım. GPS üstündeki ile çakışmamaları için devre dışı bırakılması gerekiyor.
Kolay gelsin.
 
  • Beğen
Tepkiler: Ali Osman SEVİM

Benzer konular