İlk Uçak Deneyimi - Otomatik Pilot - Pixhawkcube Sorunu

Adem ÜNLÜ

Yeni Uye
Katılım
28 Tem 2022
Mesajlar
8
Tepkime puanı
3
Yaş
34
Konum
Samsun
İlgi Alanı
Hepsi
Merhabalar. Otomatik Pilot olarak ilk modelimizi yapıyoruz. Elimizde Pixhawk Cube Orange 50a esc sunnysky x2814 1100 kv motorumuz mevcut. Gerekli bağlantılar ve model bitmiş durumda. Pixhawk ile MissionPlanner programı eşleşmiş durumda. Kumandamız Radiolink AT9S Alıcının Smbus kısmından pixhawk ın ise rcin girişlerinden girişlerimizi tamamladık. Fakat bir şekilde ne motora ne servolara güç veremiyorum bu konuda ne yapmam gerekiyor. Yardımcı olabilirseniz çok sevinirim.
 
Katılım
1 Ara 2020
Mesajlar
172
Tepkime puanı
171
Yaş
17
Konum
Üsküdar/İstanbul
İlgi Alanı
Uçak
normalde evet rcin kısmında var gözüküyor.
Yanlışınız var, Pixhawk PPM türü sinyal ile çalışır. AT9S / R9DS gibi SBUS / PWM sinyal ile çalışan cihazları Pix ile kullanabilmek için PPM Encoder denen harici cihazları kullanmanız lazım. Alıcınızı Pix'in RCIN portuna Encoder ile bağlarsanız sorunun düzeleceğini umuyorum.
 
  • Beğen
Tepkiler: Adem ÜNLÜ

Adem ÜNLÜ

Yeni Uye
Katılım
28 Tem 2022
Mesajlar
8
Tepkime puanı
3
Yaş
34
Konum
Samsun
İlgi Alanı
Hepsi
hocam sorunu buldum şuan çalışıyor encoder kullanmadan. sbus olacaktı evet. 2 gece uyumadan uğraşınca böyle oldu. 4.2.2. versiyonunda servo_gpio_mask dan kanal açmak gerekliymiş. teşekkür ederim.
 

Adem ÜNLÜ

Yeni Uye
Katılım
28 Tem 2022
Mesajlar
8
Tepkime puanı
3
Yaş
34
Konum
Samsun
İlgi Alanı
Hepsi
dediğiniz gibi doğru sbus olacak. m harfi fazladan olmuş. ama dönüştürücü olmadan sistem çalıştı şuanda.